• Home  / 
  • Tech News
  •  /  Untethered jailbreak for iOS 5.01 now available

Untethered jailbreak for iOS 5.01 now available

It’s indeed a merry Christmas for Apple jailbreak fans as @pod2g finally released the untethered jailbreak for the iOS 5.0.1. The caveat? It won’t work on A5 devices meaning it’s still a no go for iPhone 4s and iPad 2 owners.

width="250"Actually, @pod2g gave the exploit to the iPhone devteam and Chronic devteam so you can use the latest redsn0w (0.9.10) or PwnageTool to jailbreak your device. Again, this is only applicable to the iPhone 3G/s, iPhone 4, iPad 1, and the iPod Touch3G/4G running on iOS 5.0.1. If you’re on iOS 4, upgrade to the 5.0.1 first before attempting this jailbreak.

This jailbreak uses geohot’s limera1n exploit which doesn’t work for A5-based devices but @pod2g is still working on it. Meanwhile, here’s your redsn0w links.

For more technology news and gadget reviews, follow us on Facebook, Twitter and Instagram
  • thejorlanb

    DownLoading…
    Think they also have a torrent link….

    • gee just downloaded the ipsw for ipod touch 4G. 778MB!!

      • thejorlanb

        🙁 no support for my device..yet..

  • Axl

    dang….

    I wish i had an iPad so i can Play HD games…..
    And Experiment with it…

  • Dennis

    Hi,

    it does boot untethered but still “no service”. please help

    • Dennis

      iPhone 3gs

    • is that a locked unit when you bought it? if it is then you need to unlock it pa… it’s different from jailbreak

  • JmBalicano

    My girlfriend has an iPhone 4 that we kept on iOS 4.XX because there wasn’t an untethered jailbreak available for iOS 5 yet. Are there any issues with this build? Sorry, I’m really inexperienced with iDevices.

    BTW, just got the Razer DeathAdder in the mail from the PTB giveaway. Thanks, Sir Calvin!

    • nice!

      i’ve yet to jailbreak my touch 4G, naubusan ako ng time kanina sa pagdownload and backup.

  • Griswold

    Yahoo!! I wanna try the Siri for jailbroken devices. 🙂

  • Elmer

    Will these works on all basebands? I’m having second thought if I will buy a unit running on ios5.0.1 with baseband higher than 4.10.01

  • Turn on VPN from Settings > Network > VPN > ON

  • @chronic ' this so-proclaimed hacker and app developer is the creator of the Chronic Dev Team.
    This will bring a popup window, asking you to select the
    firmware file. Since the first smart phone of the company was launched in the
    market few years back the jailbreak had also been made available by the experts.